Plesk 9.0 update bei SuSE 10.2 rootie – Epic fail

Verfasst am von in admin.

als admin betreue ich mehrere mit plesk ausgestattete root- bzw. vserver. Bei den letzten updates innerhalb der 8.x.x serie gab es nie probleme. als heute bei der backupeinrichtung fuer einen klienten der pleskupdater die version 9.0 anzeigte, erwartete ich auch ein reibungsfreies update auf die neue version. als (vom update auf 7.x auf 8.x) gebranntes kind beschloss die probe aufs exempel an einem nicht ganz so ausgelasteten plesk bestueckten vserver vorzunehmen. Gottseidank (fuer diese Installation) hatte der Lizenzprobleme (1 blu hatte noch keine 9.0 Lizenz) . bei einem anderen server (diesmal ein rootserver bei 1und1) gab es den 9.0 Key.

Nach einem reibungslosen update der 8.6.0 installation wollte ich auf die 9.0 upgraden. Leider gab es auch bei mir den hier beschriebenen rpm fehler mit dem


psa-hotfix4-8.6.0 = 8.6.0 is needed by (installed) psa-hotfix5-8.6.0-8.6.0-suse10.2.build86080930.02.x86_64

auf den im thread beschriebenen Stress mit der 1und1 hotline will ich mich garnicht einlassen.

Siehe User: Chris_McKite

Ich hatte dasselbe Problem und weder ueber den Support 1und1 noch von swsoft eine klare Antwort erhalten, was da genau passiert war.
Bei der Installation der update-Komponenten von 8.6.0, die ja vor dem upgrade auf 9.0.0 alle vollstaendig installiert sein muessen, ist der gleiche hotfix wie bei Dir nicht vollstaendig installiert worden. Deinstallieren mit
rpm -e paketname

funktionierte auch nicht, weil er sagte: Nicht installiert.
Installieren ging auch nicht, weil dann die Meldung kam: schon installiert…. Huh

Nach allen moeglichen Versuchen habe ich einfach die entsprechenden RPM’s der Version 8.6.0 nochmals komplett von swsoft auf den Server geladen und per hand mit

rpm -i -force

alle pakete nochmals mit brutaler Gewalt darueber installiert.
Danach ging der Dienst smtp/Qmail wieder ueber den Plesk-Panel zu starten.
Ein Update auf die Version 9.0 habe ich allerdings nicht mehr versucht. Erstmal bin ich froh, dass alles wieder laeuft.

also werde ich rpm fuer rpm die 8.6.0 installation wieder herstellen, und die finger von der 9.0 lassen. irgendwie erninnert mich das an die „glorreichen“ zeiten von confixx. ich dachte echt sowas waere geschichte. scheint ja nicht so.

*ironie*
Danke swsoft. Nett wenn ein immer aktuell gehaltenes plesk auf einem schnellen server mit einer standard SuSE 10.2, die auf zillionen servern im internetz so ein „reibungsloses“ update bietet.
*ironie

so long
arnd

Noch keine Kommentare

Hinterlassen Sie eine Antwort

XHTML: Sie können diese Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>